Make your own free website on


But you don't have the software required to view this site properly

To be seen properly, this site, must be viewed with a browser version 4.0 or later,
with the Shockwave Flash 3.0 plug-in. If you know you have that software click on the logo to enter the site

You can use the above links to get the software.
(Note for newies: this software is free.)

Note: I would recommend that you use Internet Explorer because I haven't checked if this site is fully compatible with
Netscape Navigator. Anyway if you find any errors or incompatibilities please e-mail me.

[----Eze---- ]